IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
Website issues, Trouble doing something
Floyd
post Jan 21 2018, 05:11 PM
Post #1


Member
***

Group: Members
Posts: 809
Joined: 4-September 06
From: Boston
Member No.: 1102



On my profile, I tried to change my web link to a secure site starting "https://www...." The unmanedspaceflight software keeps adding "http://" in front of the https:// creating garbage. Any solution or should I give up on the link?


--------------------
Go to the top of the page
 
+Quote Post
nprev
post Jan 21 2018, 11:03 PM
Post #2


Senior Member
****

Group: Admin
Posts: 8107
Joined: 8-December 05
From: Los Angeles
Member No.: 602



We'll check it out; hang tight. smile.gif

EDIT: Okay, this should be a simple user fix. When you select the "Insert Link" button the popup will automatically populate it with an "http://". All you have to do is delete that & then paste in your desired link. Here's an example.


--------------------
A few will take this knowledge and use this power of a dream realized as a force for change, an impetus for further discovery to make less ancient dreams real.
Go to the top of the page
 
+Quote Post
Floyd
post Jan 22 2018, 10:23 PM
Post #3


Member
***

Group: Members
Posts: 809
Joined: 4-September 06
From: Boston
Member No.: 1102



We may be talking about two different links. From UnmannedSpaceflight.com I click on My Controls at top. On that page I select Edit Profile Information. There is a box called Your website url. That box has the incorrect link "http://https://www.forsyth.org/person/scientist/floyd-dewhirst". When I delete the http:// the remainder of the address is fine, but when I save it, it always adds back the http:// in front of the https://


--------------------
Go to the top of the page
 
+Quote Post
PaulH51
post Jan 23 2018, 12:40 AM
Post #4


Senior Member
****

Group: Members
Posts: 1483
Joined: 30-January 13
From: Penang, Malaysia.
Member No.: 6853



QUOTE (Floyd @ Jan 23 2018, 06:23 AM) *
We may be talking about two different links. From UnmannedSpaceflight.com I click on My Controls at top. On that page I select Edit Profile Information. There is a box called Your website url. That box has the incorrect link "http://https://www.forsyth.org/person/scientist/floyd-dewhirst". When I delete the http:// the remainder of the address is fine, but when I save it, it always adds back the http:// in front of the https://


I had the same issue with my link to facebook, but if you enter your address without the 's' (using the default http) it will be accepted by UMSF. Then when any users select the link in your posts etc they will automatically be directed to your hhtps page.


--------------------
Hang in there, Oppy!
Go to the top of the page
 
+Quote Post
Floyd
post Jan 23 2018, 01:20 AM
Post #5


Member
***

Group: Members
Posts: 809
Joined: 4-September 06
From: Boston
Member No.: 1102



Thank PaulH51 Simple fix


--------------------
Go to the top of the page
 
+Quote Post
nogal
post Jan 27 2018, 11:20 PM
Post #6


Member
***

Group: Members
Posts: 274
Joined: 15-June 09
From: Lisbon, Portugal
Member No.: 4824



Perhaps I'm mistaken but I think not: it seems that UMSP's https support has been discontinued.
Some months ago I started to receive a warning from the browser, when logging on, that the connection to the site is not encrypted, so the password is transmitted on the clear. The http port is being used.
Trying to connect via https gives the following error code: SSL_ERROR_RX_RECORD_TOO_LONG
Should someone look this up? Thanks
Fernando
Go to the top of the page
 
+Quote Post
RoverDriver
post Jan 29 2018, 11:55 PM
Post #7


Member
***

Group: Admin
Posts: 932
Joined: 29-September 06
From: Pasadena, CA - USA
Member No.: 1200



QUOTE (nogal @ Jan 27 2018, 03:20 PM) *
Perhaps I'm mistaken but I think not: it seems that UMSP's https support has been discontinued.
Some months ago I started to receive a warning from the browser, when logging on, that the connection to the site is not encrypted, so the password is transmitted on the clear. The http port is being used.
Trying to connect via https gives the following error code: SSL_ERROR_RX_RECORD_TOO_LONG
Should someone look this up? Thanks
Fernando



According to this URL, this error message appears while using firefox when the destination server has an incorrect definition of the SSL certificate:

https://www.namecheap.com/support/knowledge...rxrecordtoolong

So, unless there's a problem with the redirection from http to https, it seems possible it is a problem with the server your link goes to, not UMSF?

Paolo


--------------------
Disclaimer: all opinions, ideas and information included here are my own,and should not be intended to represent opinion or policy of my employer.
Go to the top of the page
 
+Quote Post
nogal
post Jan 30 2018, 12:26 AM
Post #8


Member
***

Group: Members
Posts: 274
Joined: 15-June 09
From: Lisbon, Portugal
Member No.: 4824



Hi Paolo, thanks for the reply.
Perhaps I didn't explain conveniently. The error message maybe a Firefox one but the problem also happens with Edge and Chrome (all in Windows).
If I enter http://www.unmannedspacefligt.com it works fine. If I enter https://www.unmannedspaceflight.com then I get the error. It is an SSL problem. It is not possible to log in securely to UMSF. So information may be compromised, the password for instance.
I think we used to be able to log in securely and that changed some time ago. So perhaps the SSL got misconfigured somehow? Thanks
Fernando
Go to the top of the page
 
+Quote Post
RoverDriver
post Jan 30 2018, 01:25 AM
Post #9


Member
***

Group: Admin
Posts: 932
Joined: 29-September 06
From: Pasadena, CA - USA
Member No.: 1200



QUOTE (nogal @ Jan 29 2018, 04:26 PM) *
...
If I enter http://www.unmannedspacefligt.com it works fine. If I enter https://www.unmannedspaceflight.com then I get the error. It is an SSL problem. It is not possible to log in securely to UMSF. So information may be compromised, the password for instance.
...


Ah, I was confused by the previous poster issues. Telnetting to port 443 it really seems like the https protocol is disabled.

Paolo


--------------------
Disclaimer: all opinions, ideas and information included here are my own,and should not be intended to represent opinion or policy of my employer.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic

 



RSS Lo-Fi Version Time is now: 20th September 2018 - 01:07 PM
RULES AND GUIDELINES
Please read the Forum Rules and Guidelines before posting.

IMAGE COPYRIGHT
Images posted on UnmannedSpaceflight.com may be copyrighted. Do not reproduce without permission. Read here for further information on space images and copyright.

OPINIONS AND MODERATION
Opinions expressed on UnmannedSpaceflight.com are those of the individual posters and do not necessarily reflect the opinions of UnmannedSpaceflight.com or The Planetary Society. The all-volunteer UnmannedSpaceflight.com moderation team is wholly independent of The Planetary Society. The Planetary Society has no influence over decisions made by the UnmannedSpaceflight.com moderators.
SUPPORT THE FORUM
Unmannedspaceflight.com is a project of the Planetary Society and is funded by donations from visitors and members. Help keep this forum up and running by contributing here.